Ограничение полномочий в МЧД

Дата обновления: 15.01.2024
Номер карточки: SD0055584

По умолчанию во время создания доверенности в ней указаны "Все полномочия". Значение по умолчанию можно убрать и поставить те ограничения, которые требуются.

В программе есть 2 варианта заполнения полномочий – Текстом вручную и Из классификатора полномочий ФНС.




  • Текстом вручную

Значение по умолчанию можно убрать и поставить те ограничения, которые требуются, например "Подписание Товарных накладных до 1 млн. рублей включительно" или с иным необходимым текстом, отличающимся от значений "Все полномочия" или "Полные полномочия".


После регистрации в реестре ФНС в доверенности появится специальная вкладка для автоматической проверки полномочий – "Правила проверки полномочий". 

Данная вкладка появляется в МЧД только в одном случае – если выбран вариант заполнения «Текстом вручную» (кроме значений «Полные полномочия» или «Все полномочия»). В случаях, когда выбран вариант заполнения «Из классификатора полномочий ФНС» или «Текстом вручную» со значениями «Полные полномочия» или «Все полномочия», то вкладки с проверкой полномочий не будет.

Если полномочия ограничены «Текстом вручную», но правила для автоматической проверки не заданы, то использовать данную доверенность будет невозможно. 


В программе предусмотрено два варианта настройки данных правил:

- Упрощённая настройка (включен по умолчанию);

- Скрипт на языке 1С:Предприятия.


Упрощенная настройка.
Вариант упрощённой настройки представляет собой конструктор, в котором пользователь может самостоятельно настроить правила проверки полномочий по 3 основным условиям:

-Сумма документа;

-Виды документов;

-Контрагенты.



Скрипт на языке 1С:Предприятия.
Если простых настроек недостаточно, можно выбрать вариант «Скрипт на языке 1С:Предприятия» и самостоятельно задать правила проверки полномочий с помощью скрипта, который составляет ответственный за нее сотрудник, на языке «1С:Предприятия» (составление скрипта происходит в безопасном режиме).



Что такое скрипт?
Скрипт - это программный код, созданный для автоматического выполнения определенных задач. Он запускается, совершает нужные действия, а затем завершается.

Примеры скриптов для автоматической проверки:
Ограничение по максимальной сумме и типу документа
Если Параметры.ЭлектронныйДокумент.ВидДокумента.ТипДокумента = Перечисления.ТипыДокументовЭДО.ТоварнаяНакладная Тогда
Параметры.Результат.Успех = НЕ Параметры.ЭлектронныйДокумент.СуммаДокумента > 1000000;
Если Не Параметры.Результат.Успех Тогда
Параметры.Результат.ТекстОшибки = "Превышена максимально разрешенная доверенностью сумма";
КонецЕсли;
Иначе
Параметры.Результат.ТекстОшибки = "Не разрешено подписание документов данного вида";
КонецЕсли;
Запрет работы с документами по дате
Параметры.Результат.Успех = Истина;
ДатаЗапрета = '01.01.2023';
Если ТекущаяДатаСеанса() >= ДатаЗапрета Тогда
Параметры.Результат.Успех = Ложь;
Параметры.Результат.ТекстОшибки =
трШаблон("Не разрешено подписывать документ после: %1", Формат(ДатаЗапрета, "ДЛФ=D"));
КонецЕсли;
Проверка возможности работы с типами документов из списка разрешенных
РазрешенныеТипыДокументов = Новый Массив();
РазрешенныеТипыДокументов.Добавить(Перечисления.ТипыДокументовЭДО.ТоварнаяНакладная);
РазрешенныеТипыДокументов.Добавить(Перечисления.ТипыДокументовЭДО.УПД);
РазрешенныеТипыДокументов.Добавить(Перечисления.ТипыДокументовЭДО.СчетФактура);
РазрешенныеТипыДокументов.Добавить(Перечисления.ТипыДокументовЭДО.ЗаказТовара);
ТипДокумента = Параметры.ЭлектронныйДокумент.ВидДокумента.ТипДокумента;
Параметры.Результат.Успех = Истина;
Если РазрешенныеТипыДокументов.Найти(ТипДокумента) = Неопределено Тогда
Параметры.Результат.Успех = Ложь;
Параметры.Результат.ТекстОшибки = СтрШаблон("Не разрешено подписывать документ типа: %1", ТипДокумента);
КонецЕсли;
Запрет ответа на документ по сроку в днях, кроме пользователя с полными правами
Параметры.Результат.Успех = Истина;
СрокЗапретаВДнях = 30;
Если ТекущаяДатаСеанса() - Параметры.ЭлектронныйДокумент.ДатаПодписания >= СрокЗапретаВДнях*24*60*60 И
И НЕ Пользователи.ЭтоПолноправныйПользователь() Тогда
Параметры.Результат.Успех = Ложь;
Параметры.Результат.ТекстОшибки =
СтрШаблон("Не разрешено отвечать на документ позднее %1 дней с момента его подписания", СрокЗапретаВДнях));
КонецЕсли;

  • Из классификатора полномочий ФНС

При выборе «Из классификатора полномочий ФНС» рядом с вариантом заполнения появится кнопка "+", по которой пользователь может добавить полномочия из классификатора.  Можно указать несколько значений. 



Для каждого полномочия ведется отдельная карточка с уже заполненными автоматическими правилами проверки. В них нельзя вносить изменения.



Добавить дополнительные параметры проверки можно с помощью скрипта на языке 1С:Предприятия на вкладке «Дополнительная проверка полномочий». Скрипт можно указать как в момент оформления доверенности, так и после её регистрации в распределенном реестре ФНС.



После указания перечня необходимых полномочий требуется нажать "Подписать и зарегистрировать".



При необходимости классификатор полномочий ФНС можно открыть из единого журнала «Машиночитаемые доверенности» выполнив команду Еще - Классификатор полномочий ФНС (Единый формат) или Классификатор полномочий ФНС (Формат 002).




Если при подписании документа выяснится, что доверенность не подходит по полномочиям, то процесс подписания будет прерван и будет показано следующее предупреждение.




Ваша проблема решена?

Ваше сообщение отправлено.